Create Box Sign Request API results in failure while converting

I have been testing Create Box Sign Request API using my free Developer Account, and it has been working fine until July 3rd, 2023.

However, when I tried the same request today (July 31st, 2023), the API request itself succeeded but the created Sign Request resulted in Error On Convert status.
When I created Sign Request via WebUI, the created Sign Request successfully proceeded to In Progress status.

Has there been any changes in the Box Sign API, or on its usage restriction for free Developer Accounts?

I experience the same issue! There is no more information about this status error either. I assume it’s a server error on Box’s side. Any help?

Also been getting this on almost all Box Sign requests for last couple of days. No response from Box despite being an Enterprise plan customer.

Would very much appreciate Box looking at this, it’s clear the problem is on Box’s side because if you re-attempt a request enough you will eventually get a success.

In the same boat. The signing request was working fine till last weekend and getting error since yesterday. It works intermittently but fails most of the time. I have raised with my account manager and got the information that they are in process of upgrading and heard the same thing from many clients. They are working on it and should be fixed in next few hrs; else I will escalate it.

1 Like

I encourage anyone experiencing this to write in to Box Support and file an official case with them. Despite the posts here they claim they only “have one other affected customer”

The failure rate does seem to be going down but sign requests are still actively failing to convert.

Hello Folks! Thanks for bringing this to the developer relation team’s attention. I’m in contact with support about this and will let you know when I find out more information!

Alex, Box Developer Advocate

Hi. I appreciate all of you who have reacted to this topic.

It seems to me that the problem no longer exists, but what I would like to know is that, if it was a system glitch, whether Box has officially announced (or will announce) it anywhere.


Hi @tatsumi ,

Yes it has:

For the current status you can access:

Thank you. But none of the incident reports there seems to accord with the duration of the problem we experienced. Starting from July 31st, it lasted at least 3 days.

As tatsumi noted, this was a long ongoing incident that lasted 4+ days for us, the incident reports you link to are not relevant to this (or are not accurate in their depiction)

Folks, let’s be constructive here, and assume good intention.

It’s not like Box employees wake up every morning and think “How can I make the life of my customers miserable today?”, in fact it is quite the opposite.

I saw a critical issue reported related to sign, didn’t check the timeframe, and assumed it might be this issue.

My bad, apologies.

Most of the times in these cases, most of the folks just assume there is an issue and don’t report it, making life harder for our engineering support to properly gauge the scope of incidents.

As @doc2doc mentions, the best thing to do is report, and then report, and keep reporting.


Well, I’ll leave this topic open for some time as @smartoneinok might post some further info.
I’m not blaming anybody but if anybody could give us more info (if the issue was solved or if it was due to the server’s capacity and might sometimes happen again etc.), I would be glad.

Hi Everyone, I am a developer on the sign team and wanted to give you more information about the error. Error was because increased inconsistency of one of our services replying to our service calls. This was not affecting other operations because of the retry mechanism used. But it was very apparent in Public API because retry mechanism was not enough to accommodate increased errors. We have implemented a separate special retry mechanism for these endpoints to accommodate higher errors that can happen in the future. This should resolve the issue we identified and this error would not happen again with similar reason.

Thank you for your answer! It made clear what the issue was like and that it should have been solved, so I marked the topic as solved.