Does the CLI Metadata-Query work on the level of the parent folder only?

Hi @matt.riley
When I use the “metadata-query” and specify a folder Id(parent folder), does it show results for all files under that folder and other subfolders or only under the parent folder ?

On the same note, I used the command on 1 folder that has 1 file and got the following error

box metadata-query enterprise_287697.Testing --219563937307

Unexpected API Response [400 Bad Request | 037667ddf3edfef86c49bc5058f7841c1.037667ddf3edfef86c49bc5058f7841c1] too_many_instances - Too many instances, and no supporting index available

Hi @user711
Generally speaking, Box uses the terms “parent” and “child” to only describe the direct, single level, relationship. The terms “ancestor” or “descendent” are used to describe the entire path/tree.
In the case of the “metadatda-query” call, the “ancestorfolder” parameter will limit the results to anything under that folder, including subfolders (i.e. the entire tree). If you specify an ancestor folder ID of 0, that would search everything you have in Box.

Regarding the error you’re seeing, we’re temporarily enabling our metadata query functionality on a per-enterprise basis. The enterprise ID you’re using in the above call hasn’t been enabled yet, so I’ll get you in the queue. It should just take a couple of days to get that flipped on for you. (This will be fully automatic again in a week or two).

Your continues prompt response is really appreciated, is there any possibility to know an estimated time frame ?

For your enterprise specifically? That will most likely happen on Aug. 2nd, but I can’t predict when. End of day (PST) is a safe assumption, although it could be earlier in the day. If it does finish up before the day is over, I’ll let you know in a follow up post here.

Hi @matt.riley

Just wanted to confirm that our instance has been updated as mentioned above ?

Also if you can help know how to query on “custom metadata” using CLI command, or does this only work for templates ?

Here is the screenshot to help you provide me with the command line
Custom Metadata

Hi @matt.riley

I have tried again and still getting the same error

box metadata-query enterprise_287697.recordRetentionClassificationCreationDateTrigger 182222160845

Unexpected API Response [400 Bad Request | 0b7b91a5d7078516ccd3555c9ebd6edb8.0b7b91a5d7078516ccd3555c9ebd6edb8] too_many_instances - Too many instances, and no supporting index available