Does the latest Box CLI v3.9.1 have an issue executing bulk commands

Hi Team,

The latest Box CLI v3.9.1 doesn’t recognize the file or folder id in CSV files, does anyone encounter the same issue.


Can you narrow down the command your using, or even better can you paste the command you are having issues with?


Kindly find below

Hu @user711

Thanks, I think I see the issue.

Can you convert your id column to string, instead of numbers?


Thanks for the feedback, I changed the column to text and still gives the same error.

Also I wanted to confirm that I am using the above excel sheet with Box/cli3.9.0 win32-x64 node-v14.19.3 and it works fine but the same excel sheet with Box/cli/3.9.1 win32-x64 node-v14.19.3 and it doesn’t work.


In that case let me ask the CLI team.

Hi @user711

The error you mentioned:

Missing 1 required arg:
id ID of the folder to add metadata to

I could reproduce on @box/cli/3.9.1 win32-x64 node-v14.19.3 only in case of incorrect header definition in the .csv file after I added an extra space after id ,template-key,data,as-user. But when I removed that space everything works fine again.

Can you open your file in plain notepad and make sure the header looks exactly like this:


, with no spaces or other characters between the fields?


Sorry for the late reply and thanks for your help but I checked my file and didn’t find any spaces and yet I am getting the same error

Here is my file sample

783151390695,recordRetentionClassificationCreationDateTrigger,retentionCode=ADMN-001 | Temporary Records,3875303392
820208934485,recordRetentionClassificationCreationDateTrigger,retentionCode=ADMN-001 | Temporary Records,3875303392
821974654544,recordRetentionClassificationCreationDateTrigger,retentionCode=ADMN-001 | Temporary Records,3875303392
821973706932,recordRetentionClassificationCreationDateTrigger,retentionCode=ADMN-001 | Temporary Records,3875303392