I have a question about flow to create a folder in salesforce

when I run flow to create a folder for a couple of records (using data loader to update the records to meet the criteria) I get this error “Error Occurred: An Apex error occurred: box.Toolkit.BoxApiException: Unable to create a folder for record id 5002M00001ZXLc4QAH - Details: The folder was returned with a null id.” however when I go to this record and updated to meet the criteria to trigger the flow the folder gets created without any issue any idea why I get this issue? the flow run Asynchronously using BOX Apex “create folder”

Hello :wave:,

Did you manually create the flow from scratch or did you use one of the templates?

Alex, Box Developer Advocate :avocado:

I created it from scratch but I followed the same structure that was used in the account template.

Just to confirm my understanding, the issue only happens when you use data loader? But the flow works correctly when manually updating records from the front end?

we are going live with it today and I need to solve it ASAP. SO when I go to the record and update the check box manually the flow works fine but when I check the box through ETL TOOL(DATA LOADER) on my behalf and do it with batch size 1 some of the records gets created and some are giving me the error message I mentioned above however I go to these records and trigger them manually they worked fine

just to levelset a bit - the developer forum is not meant for urgent support issues - for that you would want to file a support ticket. But I can try to help as best I can.

May I have some examples of rows that work and rows that don’t?

Yes, I already submitted a case but I was hoping that I could get some fast responses. the same record I had run in the first load didn’t work and tried it again with another run and it worked all the records are exactly the same except for different contacts

Support is going to be your best option here! They should be able to login to your salesforce account and track the errors back to box!

It’s hard to say exactly what’s going on without seeing it but perhaps there is some race condition happening. Do you only have one automated job trying to create the folder at once? I’d try running in debug mode and see if you can find anymore detailed errors. Alternatively you can also call the toolkit via Apex and retrieve the value of mostRecentError and see if this is prompting what may be wrong as well. Thanks!

unfortunately, there is no pattern for this error, Yes this is the only automated job to create box folders