Box-ui-elements support for React 18

Hi there-

This is regarding the box ui library on Github and the below issue.

Is this library actively maintained and are there plans to update this package for compatibility with React 18? We have an internal tool that we would like to integrate with Box, however, it runs on React 18+ and we cannot even install the box-ui-elements library without a flood of errors.

Thank you!

Hi @mgjll , welcome to the forum.

I’ve pinged the team, and at this point there is no official date.

However to let the product manager know how important this is I kindly ask you to submit a product feed back using Box Pulse, if you haven’t done so yet.

Sorry we couldn’t be of more help.

Best regards

Thanks for the additional information on this!