SSL connection could not be established

I am working on a Lambda function to be deployed on AWS. Application works fine locally. But fails when deployed on AWS. When I try to generate JWT token, I am getting error.

" The SSL connection could not be established. Unable to read data from transport connection. Connection reset by peer"

I am working with Windows SDK Box.V2 - 5.7.0

There are no out bound rules that’s blocking me and curl request seems to get me some response back.

Any one face similar issue and have a suggestion I could try?

Hi @user234,

Unfortunately, we haven’t encountered this problem before. Nevertheless, we’ll try to help.
I have a few questions that may help us identify the cause of the error, so I would appreciate it if you could answer them:

  1. Are you using the SDK in .NET Core or .NET Framework?
  2. Have you tried using a different authentication method, such as CCG or even a regular developer token? And if not, could you try to see if that works?
  3. Are you experiencing the mentioned error on the first call to Box?
  4. Does this happen every time the Lambda Function is executed?
  5. You mentioned that the CURL request works fine. Have you tested by making a request to the Box API?
  6. Have you tried increasing the timeout according to the instructions?

It turns out my firewall was blocking the calls. Updating firewall rules got the issue fixed.

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.