Filelink Thunderbird Add-On refuses the upload

Hello dear support team,

Perhaps someone here can help me… but first, some information:
TB: 115.6.1 (64-Bit)
OS: Windows 10
Account Type: POP
Mailbox Provider (split): SMTP (own domain) / POP (Incoming server:)
Storage Service (the one that is / isn’t working ;)): box (
AV: Windows Defender Firewall: Windows Defender (and Fritzbox)

On the subject: For many years, I have been using the Box ( add-on with Filelink (from a certain attachment size). It has always worked great. However, for some time now, the upload always fails, I can no longer use Box ( in conjunction with Thunderbird. There is no further error message, except that the “upload failed”.

I have already “uninstalled” and re-set up the service several times → no improvement. If I try it e.g. 5 times with Box (, it may work on the 5th try or already on the third try or only on the 7th try and sometimes not even then.

Since I have a lot and enough storage at Box, I am informed about the download time and frequency. Box ( is simply the better solution. Although I also use Dropbox, out of necessity, I would like to use Box ( again.
Today I tried to upload two files . . . one succeeded the other one I had to do with dropbox.
Can anyone help me with this?

Thank you in advance for your help!

With best wishes,

Hi @boxMRbox , welcome to the forum!

Not sure how I can help here, did you try to contact the author of the add-on?

I took a look at the code, but didn’t see anything particularly relevant at first glance…

Let us know…

Dear @rbarbosa,

thank you for your post.

Well, I did not find anything except this:

What I did, I asked more or less the same question in a German forum ( But I didn’t get any response, so far.

I could send an e-mail to, do you think that could help?

Have a good time!

Hi Maro,

Yes, please try that.

On our side we like to support these types of integrations as much as we can.

Best regards

@rbarbosa, just sent an e-mail . . . let’s see . . .

Best wishes